Drupal

La fi dels problemes de jQuery a Drupal

Recentmenet ha sortit un parche per al mòdul jQuery Update que permet integrar el plugin Migrate de jQuery a Drupal amb un sol clic.

Drauta agencia digitalDrauta

La fi dels problemes de jQuery a Drupal

Com integrar jQuery amb Drupal?

Com tots sabem, Drupal 7 integra de sèrie una versió molt antiga de jQuery. Això no seria un problema si no es donés el cas que molts mòduls contribuïts requereixen una versió més nova de jQuery per funcionar i que al pujar la versió alguns mòduls deixen de funcionar. Fins al moment, la solució sempre ha estat utilitzar la combinació dels mòduls jQuery Update i jQuery Multi i també buscar “parches” que solucionin els errors de JavaScript de cadascun dels mòduls que deixen de funcionar.

No obstant això, ha sortit un “parche” per al mòdul jQuery Update que simplifica la solució: només caldrà activar aquest mòdul, seleccionar la versió de jQuery desitjada i activar la nova opció que proporciona aquest “parche”: jQuery migrate plugin. Aquest plugin per a jQuery fa que les funcions deprecated que fan servir molts mòduls Drupal tornin a funcionar i, per tant, els mòduls continuïn sent funcionals al 100%. Això ens evita haver de buscar “parches” que solucionin els problemes de JavaScript de múltiples mòduls escrits per tercers i ens permet centrar-nos en la construcció de la nostra web.

Drupal JQuery Update Migrate

Vols començar un nou projecte amb nosaltres?

Necessites un servei per a la teva web? Descobreix com et podem ajudar i no dubtis en contactar amb nosaltres.